Error Permission denied (publickey) when I try to ssh

Better Stack Team
Updated on November 16, 2022

This error appears when trying to SSH into a server. The publickey in the brackets after the error message is misleading. One reason might be wrong configuration in sshd_config file and the second reason might be insufficient permissions of the authorized_keys file.

Solution - Enable password authentication

To enable the password authentication, follow these steps:

  1. Log in as a root to your system
  2. Edit the contents of the /etc/ssh/sshd_config file using the text editor:
sudo nano /etc/ssh/sshd_config
Copied!
  1. Find the PasswordAuthentication option in the file and change its value to yes so it looks like this:
# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes
Copied!
  1. Save the file and exit the editor. Then run the following command to apply the changes:
sudo service sshd reload
Copied!
Got an article suggestion? Let us know
Explore more
Licensed under CC-BY-NC-SA

This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

We are hiring.

Software is our way of making the world a tiny bit better. We build tools for the makers of tomorrow.

Explore all positions →

Reliability is the
ultimate feature

Delightful observability tools that turn your logs & monitoring into a secret weapon for shipping better software faster.

Explore Better Stack